PDA

View Full Version : billingapi and start/stop


goldenmaza
03-07-2014, 01:40 PM
Hello

I would like to know if this has been updated or something? I'm using the following data to send by cURL to the billingapi.aspx file that is on our server, and I get the response from the call that the function doesnt exists:

"tcadmin_username" = ***
"tcadmin_password", = ***
"function" = "StopByBillingId"
"client_package_id" = #
"response_type" = "xml"

Results:
-1
UnknownFunction
0
StopByBillingId

I'm using the values from the start_stop_restart.htm-file found under the BillingApiExamples.zip that is found on this website. I think our server is running the 1.0 version of tcadmin.

Any ideas to the reason to this problem?

King regards
Richard

goldenmaza
03-17-2014, 07:34 AM
anyone?

if it's not the billingapi file, could I use the service.aspx file to do the same work?

Raizio
03-17-2014, 12:31 PM
Hmm, that might be it, I think the BillingApiExamples.zip are from help.tcadmin.com

This is the tcadmin 2.0 documentation I do believe. I tried looking for v1.0 documentation, but I couldn't find a hint.

ECF
03-17-2014, 03:42 PM
If you need info on the V1 billing api please put in a support ticket. Luis can send the zip file to you containing the examples.

goldenmaza
04-11-2014, 06:05 AM
Ok, this one is now resolved. Luis gave me that I needed to get reach the services and turning them on and off. Although, my problem now lies with getting the service id in the first place. I'm not that customed with TCAdmin, does TCAdmin come with an aspx file that does this for you?

Edit: When I call billingapi, I get the following text: TCADMIN BILLING API DOCUMENTATION, why?